Page 1 of 1

Empty App won't load in Edge

Posted: Mon Jul 01, 2019 6:33 am
by TaterJuice
New Empty CSHTML5 v1.2.2 app does not load in Microsoft Edge.

Steps to reproduce:
1. Create a new, empty CSHTML5 app
2. Run
3. Click "Run in Browser"
3.a If default browser is not Edge, copy file URL into Edge and load.

Result:
Progress bar loads empty and app hangs. Console shows error: "SCRIPT16389: SCRIPT16389: Unspecified error." at JSIL.Browser.js (416, 3)

Re: Empty App won't load in Edge

Posted: Tue Jul 02, 2019 4:30 am
by JS-Support @Userware
Thanks for reporting this issue. We are going to look into it asap.

Re: Empty App won't load in Edge

Posted: Tue Jul 02, 2019 5:37 am
by JS-Support @Userware
Hi,

We just attempted to reproduce the issue but were unable to do so.

Please find here a video that shows what we did:
Recording CSHTML5 on Edge issue.zip
(2.79 MiB) Downloaded 40 times


Could you please let me know which version of Edge you have? (please click "..." then "Settings", then scroll down)

Thanks

Re: Empty App won't load in Edge

Posted: Tue Jul 02, 2019 7:22 am
by TaterJuice
Looks like I have a newer build of Edge than you do in your video:

I am running
Microsoft Edge 44.17763.1.0

Your video shows
Microsoft Edge 42.17134.1.0

Re: Empty App won't load in Edge

Posted: Tue Jul 02, 2019 7:41 am
by JS-Support @Userware
Thanks. We'll try with the newer version asap.

Re: Empty App won't load in Edge

Posted: Thu Jul 11, 2019 3:41 am
by JS-Support @Userware
Hi,

We have reproduced and fixed the issue. Please expect the fix to be available in v1.2.4 shortly.

Notes:
- the issue is not present if you run from http://localhost
- the issue is not present in version 2.x

Thanks.
Regards

Re: Empty App won't load in Edge

Posted: Tue Aug 06, 2019 7:42 am
by TaterJuice
Is there any update about a release for this issue?

Re: Empty App won't load in Edge

Posted: Fri Aug 09, 2019 4:35 am
by JS-Support @Userware
Hi,

As we are attempting to maintain both the v1.x and v2.x branches in parallel (so that they have the same features with a different underlying technology), we have some delay to update v1.x because the recent changes in the v2.x branch have broken our internal builds of v1.x. We are working to fix it and we will post v1.2.4 asap.

Thanks a lot.
Regards

Re: Empty App won't load in Edge

Posted: Thu Aug 22, 2019 7:33 am
by TaterJuice
JS-Support @Userware wrote:Hi,

As we are attempting to maintain both the v1.x and v2.x branches in parallel (so that they have the same features with a different underlying technology), we have some delay to update v1.x because the recent changes in the v2.x branch have broken our internal builds of v1.x. We are working to fix it and we will post v1.2.4 asap.

Thanks a lot.
Regards


Is there any way you can share the change or help me implement your fix myself, so I can make my own release before you release 1.2.4?

Thank you!

Re: Empty App won't load in Edge

Posted: Wed Sep 11, 2019 3:38 am
by JS-Support @Userware
TaterJuice wrote:Is there any way you can share the change or help me implement your fix myself, so I can make my own release before you release 1.2.4?


Sorry for the delay.

Sure. Here is how to patch:

Please open the file "JSIL.Browser.js" and replace the following line:

Code: Select all

if (typeof (localStorage) !== "undefined")

with:

Code: Select all

  var isIEOrEdgeWithFileProtocol = window.IE_VERSION && document.location.protocol === "file:";
  if (!isIEOrEdgeWithFileProtocol && typeof (localStorage) !== "undefined")


You can do the replacement either in the generated JavaScript files (under bin/Debug/Output) or, if you want to persist the changes, you can patch the file at:
C:\Program Files (x86)\MSBuild\CSharpXamlForHtml5\InternalStuff\Libraries\JSIL.Browser.js

Thanks.
Regards

Re: Empty App won't load in Edge

Posted: Thu Sep 12, 2019 10:14 am
by TaterJuice
Thank you!