[SOLVED] to deselect combobox: comboBox.SelectedIndex = -1; NOT Working !

Please report bugs here. If you are unsure whether something is a bug or an expected behavior, please post it on the "Technical Support" forum instead, and wait for a moderator to handle/move the post.
Sesztak
Posts: 172
Joined: Fri Jun 24, 2016 2:19 am

[SOLVED] to deselect combobox: comboBox.SelectedIndex = -1; NOT Working !

Postby Sesztak » Tue Jul 19, 2016 3:19 am

Dear JS-Support,

We have to unselect combox items programattically:

to deselect combobox: comboBox.SelectedIndex = -1; NOT Working !

instead: allways the first element (item) selected in the UI.

I think it is a bug.

Is there any workaround to this problem?

Backgound info: we fetch a list of items to combobox ( by fill it with .Items.Add(item) ),
and we need it to be unselected at the very first time - as there is no default or privileged item in the list.

Thanks for your kind reply,
Best Regards,
Péter

JS-Support @Userware
Site Admin
Posts: 1067
Joined: Tue Apr 08, 2014 3:42 pm

Re: to deselect combobox: comboBox.SelectedIndex = -1; NOT Working !

Postby JS-Support @Userware » Tue Jul 19, 2016 5:09 am

Thanks for reporting this issue. We are going to fix it before the end of the week.

JS-Support @Userware
Site Admin
Posts: 1067
Joined: Tue Apr 08, 2014 3:42 pm

Re: to deselect combobox: comboBox.SelectedIndex = -1; NOT Working !

Postby JS-Support @Userware » Sun Jul 24, 2016 11:53 am

Sorry, the fix did not make it for Beta 9.0 (available in a few hours) but it will be released soon after. I will keep you updated.

Thanks.
Regards,
JS-Support

JS-Support @Userware
Site Admin
Posts: 1067
Joined: Tue Apr 08, 2014 3:42 pm

Re: to deselect combobox: comboBox.SelectedIndex = -1; NOT Working !

Postby JS-Support @Userware » Mon Aug 29, 2016 6:44 am

Hi,

We completely revamped the handling of ItemsSource and the ComboBox in Beta 9.1.

The issue should now be fixed.

You can download it from:

http://forums.cshtml5.com/viewforum.php?f=6

Thank you.
Regards,
JS-Support


Return to “Bug Reports”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

 

 

cron