methode parameters is null at WCF server side

Please report bugs here. If you are unsure whether something is a bug or an expected behavior, please post it on the "Technical Support" forum instead, and wait for a moderator to handle/move the post.
Sesztak
Posts: 172
Joined: Fri Jun 24, 2016 2:19 am

methode parameters is null at WCF server side

Postby Sesztak » Wed Jul 06, 2016 7:58 am

Dear Support Team,
I have a very strange bug (using 8.3 beta):
I have a very simple methode signature, like red marked :

[ServiceContract]
[XmlSerializerFormat]
public interface IServiceKassza
{
[OperationContract]
string GetData(int value);


[OperationContract]
ServerTest GetTestServerData (int value);


//[OperationContract]
//SajátBool Generate_settingsxml_Sample();

[OperationContract]
string GenerateSettingsXmlSample();


[OperationContract]
string SikeresEALoginKiserlet(string LoginNév, string LoginJelszó, Guid FelhasználóEgyediAzonosítója, Guid FelhasználóKasszájánakEgyediAzonosítója);
}

When I call this very simple function "SikeresEALoginKiserlet" from CSHTML5 client side
var response = _kliens.SikeresEALoginKiserlet("John", "Smith", Guid.NewGuid(), Guid.NewGuid());

, I allways got null or default values at IIS Server side:
(debug/attached to right IIS process)
LoginNév = null
LoginJelszó = null
FelhasználóEgyediAzonosítója = {00000000-0000-0000-0000-000000000000}
FelhasználóKasszájánakEgyediAzonosítója = {00000000-0000-0000-0000-000000000000}

The problem is only at browser, and no problem with simulator.

Any idea?
Thanks in advance,
Best Regards,
Péter

Sesztak
Posts: 172
Joined: Fri Jun 24, 2016 2:19 am

Re: methode parameters is null at WCF server side

Postby Sesztak » Wed Jul 06, 2016 9:21 am

I've found a problem or a workaround to this:

Do NOT USE non-english characters in methode signatures (characters with accents: öüóőúéáűíÖÜÓŐÚÉÁŰÍ), like :
string LoginNév

USE:
string LoginNev

Any deeper explanation from Support Team ?
Is it a normal restriction or a bug ?

Bg,
Péter

JS-Support @Userware
Site Admin
Posts: 1067
Joined: Tue Apr 08, 2014 3:42 pm

Re: methode parameters is null at WCF server side

Postby JS-Support @Userware » Sun Jul 24, 2016 11:58 am

For reference, this issue is now being discussed on this topic:

http://forums.cshtml5.com/viewtopic.php?f=5&t=5504


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests

 

 

cron