Blocking GUI | Visual Studio 2013

Please report bugs here. If you are unsure whether something is a bug or an expected behavior, please post it on the "Technical Support" forum instead, and wait for a moderator to handle/move the post.
TobiasDonaubauer
Posts: 15
Joined: Wed Nov 04, 2015 5:29 am

Blocking GUI | Visual Studio 2013

Postby TobiasDonaubauer » Sat Feb 13, 2016 1:42 am

I have a problem with blocking GUI in VST 2013.

I open a class and start to write something. I do not save the file.

I open another class in VST 2013 and every 5 - 8 times GUI is blocking for 10 seconds. It seems to be somehow linked with the .xaml Designer and some background processes. I already tried another machine, but problem still exists.

Any workaround for that? Could I turn on/off something to avoid this?

Thanks, Tobias

JS-Support @Userware
Site Admin
Posts: 1063
Joined: Tue Apr 08, 2014 3:42 pm

Re: Blocking GUI | Visual Studio 2013

Postby JS-Support @Userware » Mon Feb 15, 2016 1:57 am

Dear Tobias,

Thanks for your message.

We have received reports of similar issues and we are currently investigating them. They indeed appear to be related to the design-time compilation of the solution, especially when switching from a tab to another or when saving a file. I will keep you updated as soon as we have news about this topic.

Regards,
JS-Support

TobiasDonaubauer
Posts: 15
Joined: Wed Nov 04, 2015 5:29 am

Re: Blocking GUI | Visual Studio 2013

Postby TobiasDonaubauer » Mon Feb 15, 2016 7:41 pm

Thanks for your info! It seems like that. Is it possible to turn off design-time compilation in between?

JS-Support @Userware
Site Admin
Posts: 1063
Joined: Tue Apr 08, 2014 3:42 pm

Re: Blocking GUI | Visual Studio 2013

Postby JS-Support @Userware » Mon Feb 22, 2016 5:28 am

Unfortunately turning this off would lead to errors in VS that say that the UI elements defined in the XAML file with x:Name="..." are unknown to the C# code. We are going to keep you updated on this matter.

TobiasDonaubauer
Posts: 15
Joined: Wed Nov 04, 2015 5:29 am

Re: Blocking GUI | Visual Studio 2013

Postby TobiasDonaubauer » Wed May 18, 2016 6:34 pm

My Project is getting bigger (up to 500 classes). And this problem is getting worse.

Problem exists when:
1) Adding project files (always)
2) Deleting project files (always)
3) Switching from designer to code behind (not always, but very often)

It takes now up to 20 seconds to execute one of this operations.

I am still using VST 2013.

It seems some foreground task is blocking VST 2013 UI. Is it not possible to execute this task in the background?

If you like to I could also share my screen with you and show you the problem!

Any progress on that?

rkmore
Posts: 55
Joined: Mon Dec 07, 2015 1:53 pm

Re: Blocking GUI | Visual Studio 2013

Postby rkmore » Thu May 19, 2016 3:41 am

I have this issue in VS2015 but not in VS2013.

In vs 2015 I was able to improve things by turning off

tools, options >> text editor >> C#, Advanced and uncheck Enable full solution analysis.

But there is no such option in VS2013

Interestingly in my VS2013 any x:Name values are not available in intellisense until I have compiled once. I have no idea why (I must have set some setting at some point in the past but I don't know what), but it make the tool at least usable.

I have also found that keeping the number of tabs open to a bare minimum really helps, and closing XAML tabs whenerver possible also makes a big difference.

This really should be near the top of the bug fixes IMO. Many potential users encountering this issue may stop using the tool and never come back.

TobiasDonaubauer
Posts: 15
Joined: Wed Nov 04, 2015 5:29 am

Re: Blocking GUI | Visual Studio 2013

Postby TobiasDonaubauer » Thu May 19, 2016 10:04 am

Thanks @rkmore

I have tried to use VST 2015 Community Edition.

But I was unable to find 'tools, options >> text editor >> C#, Advanced and uncheck Enable full solution analysis.'

What VST 2015 Edition are you using? I am really looking for a solution or workaround.

I like this project but currently this blocking of UI is frustrating me.

JS-Support @Userware
Site Admin
Posts: 1063
Joined: Tue Apr 08, 2014 3:42 pm

Re: Blocking GUI | Visual Studio 2013

Postby JS-Support @Userware » Thu May 19, 2016 6:23 pm

This is indeed in our top priority bugs list.
It seems to be related to VS compiling the solution in background. I'll keep you updated as soon as we find a solution.

Thanks.
Regards,
JS-Support

rkmore
Posts: 55
Joined: Mon Dec 07, 2015 1:53 pm

Re: Blocking GUI | Visual Studio 2013

Postby rkmore » Fri May 20, 2016 4:07 am

In VS2013 try the following:

Options>>Text Editor>>C#>>Advanced

turn off "Underline errors" and "Show live semantic errors"



In VS2015 these options are renamed so

Options>>Text Editor>>C#>>Advanced

turn off "Show Diagnostics for closed files"

TobiasDonaubauer
Posts: 15
Joined: Wed Nov 04, 2015 5:29 am

Re: Blocking GUI | Visual Studio 2013

Postby TobiasDonaubauer » Fri May 20, 2016 9:01 pm

Thanks @rkmore.

I tried your solution in VST 2013 and also VST 2015. None of them was actually working for me.

The only thing what really works for me is always compiling the solution. While compiling UI is not blocking.

I am now able to reproduce the bug:
1) open xaml file and also code behind file for this control
2) only keep this two files opened
3) enter something within the xaml file: e.g. eeeeeee in top of the file
4) switch to code behind by clicking the tab
5) now UI is blocking for ten or more seconds


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests