Search found 16 matches

Go to advanced search

by ThibTib
Thu Feb 16, 2017 6:47 am
Forum: Technical Support
Topic: RowDefinition or ColumnDefinition margins with WPF star (*)
Replies: 3
Views: 1988

Re: RowDefinition or ColumnDefinition margins with WPF star (*)

Hi,

does this issue was resolved on the last review ?
by ThibTib
Sun Jan 29, 2017 5:54 am
Forum: Technical Support
Topic: RowDefinition or ColumnDefinition margins with WPF star (*)
Replies: 3
Views: 1988

Re: RowDefinition or ColumnDefinition margins with WPF star (*)

Ok thank you.
To be complete just in case, the problem is the same for width of columns.
by ThibTib
Sun Jan 29, 2017 3:42 am
Forum: Technical Support
Topic: RowDefinition or ColumnDefinition margins with WPF star (*)
Replies: 3
Views: 1988

RowDefinition or ColumnDefinition margins with WPF star (*)

Hi, I have a problem with my interface. In order to be fully compatible with every kind of devices (speaking of different sizes of screens), I would like to define every columns and rows of my grids using the star feature (*) as in WPF, like that for example : <Grid VerticalAlignment="Stretch&q...
by ThibTib
Tue Oct 11, 2016 3:50 am
Forum: Technical Support
Topic: Templating Scrollviewer ?
Replies: 0
Views: 7772

Templating Scrollviewer ?

Dear JS-Support, my question is simple : is it possible to make a XAML style template of a ScrollViewer ? Btw I would like to know if it's possible to hide the scrollbar without losing scroll feature ? In WPF you can set the Vertical/HorizontalScrollBarVisibility to "Hidden" and it will ke...
by ThibTib
Thu Sep 01, 2016 4:21 am
Forum: Technical Support
Topic: [SOLVED] MVVM - OnPropertyChanged problem - Setter not set
Replies: 3
Views: 2417

Re: [SOLVED] MVVM - OnPropertyChanged problem - Setter not set

Here is what was missing in my XAML : <ComboBox Grid.Row="1" ItemsSource="{Binding ListOfCategories}" DisplayMemberPath="Libelle" SelectedValuePath="Code" SelectedValue="{Binding SelectedCategorie, UpdateSourceTrigger=PropertyChanged, Mode=TwoWay}" /...
by ThibTib
Thu Sep 01, 2016 3:49 am
Forum: Technical Support
Topic: [SOLVED] MVVM - OnPropertyChanged problem - Setter not set
Replies: 3
Views: 2417

Re: MVVM - OnPropertyChanged problem - Setter not set

So I tested it in a WPF app : it works well, when I change the comboBox value, the debugger comes in the setter of the SelectedValue.

Does it exist some specific tips to use INotifyPropertyChanged in a CSHTML5 app, or do I have to dig deeply in my implementation of it ?
by ThibTib
Thu Sep 01, 2016 3:45 am
Forum: Technical Support
Topic: [SOLVED] "System.Runtime.CompilerServices.CallSite '1 has not been defined" error
Replies: 4
Views: 5734

Re: "System.Runtime.CompilerServices.CallSite '1 has not been defined" error

I finally found the solution : Do not create a separate project containing objects which are sent by the Webservice : it will force you to use a CSHTML5 dll (have to be to be referenced by your app) and it's not compatible with a WCF response flux. You must declare classic .Net classes directly insi...
by ThibTib
Mon Aug 29, 2016 12:18 pm
Forum: Technical Support
Topic: [SOLVED] MVVM - OnPropertyChanged problem - Setter not set
Replies: 3
Views: 2417

[SOLVED] MVVM - OnPropertyChanged problem - Setter not set

Hi, my problem is in my MVVM system. I have a XAML view and a ViewModel. When I change the value of my ComboBox, the setter of the property of the selected value of the combobox is not set (ie the debugger do not pass in it), and so the NotifyPropertyChanged is not raised, and so my view is not refr...
by ThibTib
Mon Aug 29, 2016 12:03 pm
Forum: Technical Support
Topic: [SOLVED] "System.Runtime.CompilerServices.CallSite '1 has not been defined" error
Replies: 4
Views: 5734

Re: "System.Runtime.CompilerServices.CallSite '1 has not been defined" error

Hi and thx for you reactivity ! Yes I've put [XmlSerializerFormat] to my interface (I had put to my class directly, it does not work). First step is done :) So now I have a new problem. I must explain to you that my WCFService returns objects which are from an other dll - an empty class library (C#/...
by ThibTib
Sun Aug 28, 2016 5:55 am
Forum: Technical Support
Topic: [SOLVED] "System.Runtime.CompilerServices.CallSite '1 has not been defined" error
Replies: 4
Views: 5734

[SOLVED] "System.Runtime.CompilerServices.CallSite '1 has not been defined" error

Hi, as said in the subject, I get an error when calling my WCF service (which works well on the simulator). Here is the creation of the client : class ServiceClientSingleton { private static ServiceClient _client; static readonly object _lock = new object(); private static ServiceClient ServiceClien...
by ThibTib
Tue Aug 09, 2016 11:55 pm
Forum: Technical Support
Topic: Problem: authenticate users for access the application
Replies: 4
Views: 4359

Re: Problem: authenticate users for access the application

You could use a web service ?
by ThibTib
Wed Aug 03, 2016 3:15 am
Forum: Technical Support
Topic: [RESOLVED] Simulator does not launch
Replies: 5
Views: 3096

Re: [RESOLVED] Simulator does not launch

I mean "from its .exe file".
by ThibTib
Tue Jul 12, 2016 12:22 am
Forum: Technical Support
Topic: [RESOLVED] Simulator does not launch
Replies: 5
Views: 3096

Re: Simulator does not launch

Hi,

I finally find the problem (without intention).

I've tried to activate my pro version and I remembered that my anti-virus blocked this setup.

So I deactivate my anti-virus and ran the simulator from its setup, it worked.
by ThibTib
Mon Jul 11, 2016 9:19 am
Forum: Technical Support
Topic: [RESOLVED] Simulator does not launch
Replies: 5
Views: 3096

Re: Simulator does not launch

Hi and thanks for your rapid answer. Yes it worked just fine in the same machine with the old version 8.2. What I'm thinking right now is that I've bought the professional version of the product. I've validated this product in my other computer and I think the pro version is not validated in my actu...
by ThibTib
Mon Jul 11, 2016 7:40 am
Forum: Technical Support
Topic: [RESOLVED] Simulator does not launch
Replies: 5
Views: 3096

[RESOLVED] Simulator does not launch

Hello, I've downloaded the new version of the Beta (8.4) and I've a problem : the simulator does not launch when I try to debug my application. My visual studio build my solution, but just after, at the time of runtime, my visual studio freeze and I need to kill it with the task manager. I've tried ...
by ThibTib
Mon Jun 06, 2016 1:24 am
Forum: Technical Support
Topic: [RESOLVED] Call functionnalities of mobile device
Replies: 1
Views: 1454

[RESOLVED] Call functionnalities of mobile device

Hi,

first, I have to say that CSHTML5 is great :)

I would like to develop an smartphone application, but I'll probaly need to use tools of the device (ie camera, microphone...).
Is there a way, at this moment or later, to work with ?

Do I have to write specific code ? If yes, how ?

Thx

Go to advanced search

 

 

cron